Problems connecting American Express accounts
Incident Report for Snoop Status
Resolved
American Express has now resolved this issue.
Posted Jan 07, 2021 - 09:32 GMT
Update
We are continuing to investigate this issue.
Posted Jan 06, 2021 - 16:27 GMT
Investigating
American Express is experiencing some problems with its app and online banking services, meaning customers may not be able to connect your account to Snoop. This has been raised with them and is being investigated as a priority.
Posted Jan 06, 2021 - 16:25 GMT
This incident affected: American Express.