RBS connection problems
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Oct 28, 2020 - 09:50 GMT
Investigating
Some customers are experiencing problems when attempting to connect their RBS accounts to Snoop.

This has been raised with RBS who is investigating.
Posted Oct 20, 2020 - 11:24 BST
This incident affected: RBS.