Virgin Money Android account connections and reconnections
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Oct 10, 2022 - 13:56 BST
Identified
Virgin Money's Android app is no longer working as expected via open banking, meaning customers wishing to connect or reconnect their Current Account to Snoop may experience problems.

Virgin Money is aware of the problem and is working on a fix.
Posted Jul 28, 2022 - 19:24 BST
This incident affected: Virgin Money Current Account.