Incorrect balances for RBS and Natwest customers
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Jun 10, 2020 - 14:06 BST
Investigating
A recent system change made by RBS (affecting the RBS brand itself as well as Natwest) has meant that some customer's balances are incorrect. We are working on resolving this with RBS as soon as possible.
Posted May 22, 2020 - 13:03 BST
This incident affected: NatWest and RBS.