Clydesdale Bank, Yorkshire Bank, B and Virgin Money Current Account connections
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 14:22 BST
Investigating
Some customers are experiencing problems when attempting to connect their CYBG accounts to Snoop.

This has been raised with CYBG who is investigating.
Posted Oct 14, 2020 - 13:24 BST
This incident affected: Virgin Money Current Account.