TSB - Account connection issues & duplicate pending transactions
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted May 30, 2020 - 07:20 BST
Update
The issue relating to pending transactions is now fixed. Account connection and refreshes remain intermittent.
Posted May 29, 2020 - 12:26 BST
Update
We are also experiencing some account connection problems - TSB are investigate this issue.
Posted May 27, 2020 - 13:27 BST
Investigating
Duplicate pending transactions for some TSB customers. We are investigating.
Posted May 26, 2020 - 09:38 BST
This incident affected: TSB.