Virgin Money connection issues
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 11:04 BST
Investigating
Virgin Money have reported an issue with their open banking connections, so connecting your account to Snoop may not be possible at the moment. This issue do not impact their Credit Card connections. We'll provide an update on this issue as soon as we know more.
Posted Apr 07, 2021 - 10:39 BST
This incident affected: Virgin Money Current Account and Virgin Money Savings.