Problems connecting to banks
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted May 20, 2020 - 12:16 BST
Update
We are continuing to investigate this issue.
Posted May 20, 2020 - 12:16 BST
Investigating
We have some intermittent problems with connecting to banks and credit card providers meaning some customers are unable to connect their accounts to Snoop.
Posted May 20, 2020 - 09:07 BST
This incident affected: Snoop App and Account Linking & Updates.