Virgin Money Credit Card connection problems
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 16:23 GMT
Investigating
Virgin Money is experiencing some problems meaning customers are unable to connect their Virgin Money credit cards to Snoop at the moment. This is being investigated.
Posted Oct 27, 2020 - 14:52 GMT
This incident affected: Virgin Money Credit Card.