TSB account connections and refreshes
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted May 15, 2023 - 15:57 BST
Investigating
TSB continue to experience problems with the reliability of their service.

This may mean you're not able to connect or reconnect your account to Snoop right now, or that your account balances and transactions occasionally stop updating.

This remains under investigation by TSB with Snoop pushing for resolution asap.

If you have time, please do raise a formal complaint with TSB as it would help them understand how important this is to their customers.
Posted Jan 21, 2022 - 09:31 GMT
This incident affected: Account Linking & Updates and TSB.