Nationwide connection problems
Incident Report for Snoop Status
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 09:07 BST
Investigating
Nationwide are currently having problems with customers connecting their accounts via Open Banking - we'll let you know as soon as they have resolved the issue.
Posted Apr 13, 2021 - 11:39 BST
This incident affected: Nationwide.